Back to overview
Downtime
Ubuntu-Server-Nas and PI Fail Over are down
Oct 1, 2025 at 11:21pm UTC
Affected services
Ubuntu-Server-Nas
Resolved
Oct 1, 2025 at 11:30pm UTC
Everything recovered.
Affected services
Created
Oct 1, 2025 at 11:21pm UTC
Everything went down. POWER OUTAGE
Affected services