Back to overview
Maintenance

All systems will be down.

Feb 2, 2026 at 3:30pm UTC  –  Feb 2, 2026 at 6:01pm UTC
Affected services
Ubuntu-Server-Nas
ashdevtools.org

Resolved
Feb 2, 2026 at 6:01pm UTC

Everything back up.

Created
Feb 2, 2026 at 3:30pm UTC

Adding more storage :)